LumberJocks

planer won't switch speeds

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Dan2146 posted 02-28-2021 06:20 PM 191 views 0 times favorited 3 replies Add to Favorites Watch
View Dan2146's profile

Dan2146

3 posts in 48 days


02-28-2021 06:20 PM

Topic tags/keywords: question planer

My Delta 22-580 planer works fine at the dimensioning speed but when I switch to finishing speed (while running per instructions) the feed rollers stop. The belt and gears are moving to drive the blades but the chains stop and the rollers do not move. Any thoughts?


3 replies so far

View Dan2146's profile

Dan2146

3 posts in 48 days


#1 posted 02-28-2021 06:53 PM

In the time it took for my post to be approved I fixed the problem. Disassembled the planer, cleaned and lubricated all moving parts and reassembled. That did the trick. Both speeds work now. Would be nice if the manufacturer could isolate the gears better to protect from dust clogging the works.

View Madmark2's profile

Madmark2

2485 posts in 1639 days


#2 posted 02-28-2021 07:05 PM

If you can identify dust infiltration points a little aluminum tape does wonders. I had to do that on my table router to cover the handle holes when I table mounted it.

-- The hump with the stump and the pump!

View Foghorn's profile

Foghorn

1143 posts in 437 days


#3 posted 03-01-2021 01:29 AM

I only ever use finishing speed on my 580. Not sure if the dimensioning speed works! :)

-- Darrel

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com