LumberJocks

I'd rather be lucky than good

  • Advertise with us

« back to Focus on the Workspace forum

Forum topic by hairy posted 01-15-2021 10:57 PM 347 views 0 times favorited 2 replies Add to Favorites Watch
View hairy's profile

hairy

3210 posts in 4536 days


01-15-2021 10:57 PM

A few years back I built a cart for a vacuum pump and assorted vacuum chuck items.

A few weeks back I bought a new air compressor.

https://www.amazon.com/California-Air-Tools-CAT-4610S-Compressor/dp/B01G75OV1K/ref=sr_1_2?dchild=1&keywords=california+air+compressor+4610s&qid=1610750884&sr=8-2

Before it got here I was thinking of a cart for it, I don’t like to waste bench space as storage.

It fits like it was made for it, and it’s pure dumb luck cause I didn’t plan it like this.

I haven’t used it enough for a review, but I’ve had no problems with it. It is what they say it is. I bought it online from Home Depot. Less than 24 hours later it was on the porch.

-- You can lead a horse to water, but you can't tie his shoes. Blaze Foley


2 replies so far

View therealSteveN's profile

therealSteveN

7210 posts in 1578 days


#1 posted 01-16-2021 03:56 AM

Hairy, I got this one about 3 years ago for a in the garage for car tires, and occasional air tool jobs in the house.

We had an old cheapo pancake deal before, and it would deafen you. The first time I turned my California air compressor on, I had to bend down to make sure it was running. So quiet, the tank holds air forever, and even though the numbers look worse than our old pancake, it works like you want it to.

Thinking you’ll be very happy.

-- Think safe, be safe

View Ocelot's profile

Ocelot

2863 posts in 3642 days


#2 posted 01-16-2021 10:34 PM

The harbor freight “Ultra quiet” series seems to be the same thing.

One time I plugged mine in and turned it on and it didn’t run. It was only a few months old. I had not used it in about 2 months. I was bummed! After a few minutes I figured out why it didn’t run. It still had 120PSI sitting in it. It didn’t leak down at all in 2 months!

You would think I would learn, but another time I carried it out to air up some tires, set it down by the truck, got out the extension cord. Plugged it in and – Nothing! So, I figured the GFI on the porch was tripped … went inside and checked that, then I figured the cord was bad, then the outlet. Finally, I looked at the gauge. 120 again!

Hopefully I won’t make that mistake again.

I think the 2Gal Harbor Freight one is the same as the CAT.

Nice cart, by the way!

-Paul

-- I intended to be a woodworker, but turned into a tool and lumber collector.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com