LumberJocks

Got an older Rockwell jointer today

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by pbesong posted 03-23-2019 12:57 AM 485 views 0 times favorited 18 replies Add to Favorites Watch
View pbesong's profile

pbesong

13 posts in 611 days


03-23-2019 12:57 AM

Topic tags/keywords: jointer rockewll delta

I was at a Habitat for Humanity ReStore store today (I go weekly) and found an old Rockwell Delta 4” jointer for sale for $60. The blades appear to be okay but I’m guessing would need sharpened. I’m not sure it’s the original motor (doubt it), as it doesn’t say Rockwell on it. I found a manual online, but it doesn’t list the motor specs. Is there somewhere i can find out what it should have as far as power/RPMs? I wasn’t really looking for a jointer, but for $60 I would be kicking myself for not taking a chance on it. It stated that the motor works, but I haven’t tried it yet. It needs a wire so I can plug it in and has a non-standard switch box (probably a good thing). The pulley belt says Rockwell on it so it’s probably an original or replacement.

Found the manual and it lists 3 possible motors. They are either 1/3 or 1/2 HP and the motor on mine is only 1/4. Where might I find a suitable motor if it won’t cut properly?


18 replies so far

View cjfarmer's profile

cjfarmer

74 posts in 39 days


#1 posted 03-23-2019 01:46 AM

Maybe a lucky find for you. Whatever motor and pully combo u put on it make sure the rpm computes to real close to the specs for the jointer. Im thinking of replacing the motor on a jointer i just got. Its underpowered and.i want to use it almost daily.

-- Who is we and where is here? - bullwinkle

View pbesong's profile

pbesong

13 posts in 611 days


#2 posted 03-23-2019 01:51 AM

i found a video online that the guy said it should run around 4200 RPM. don’t know where he got his info. It wasn’t in the manual. the motor i have now says 1750 RPMs, but depending on the size of the 2 pulleys it could reach 4200 rpms I guess.

View BlasterStumps's profile

BlasterStumps

1266 posts in 765 days


#3 posted 03-23-2019 01:58 AM

Once I made sure the blades were sharp, I would give the 1/4 hp motor a try. I would think it should do fine.

-- "I build for function first, looks second. Most times I never get around to looks." - Mike, western Colorado

View pbesong's profile

pbesong

13 posts in 611 days


#4 posted 03-23-2019 02:02 AM

yeah that’s the plan for now. need to put a switch and wire on it so i can plug it in.

View MrUnix's profile

MrUnix

7298 posts in 2525 days


#5 posted 03-23-2019 02:10 AM

What is the serial number so you can date it and verify the model number… from there you can look at the Delta catalog to see what was available at the time. Keep in mind that back in the day, those machines typically shipped without a motor. If you wanted one, it was an optional item and purchased separately.

I think 1/4hp for a 4” jointer would be fine. You don’t need a lot of HP for a jointer.

Cheers,
Brad

-- Brad in FL - In Dog I trust... everything else is questionable

View pbesong's profile

pbesong

13 posts in 611 days


#6 posted 03-23-2019 02:11 AM

i know it’s a model 37-290 and found its manual.

View Aj2's profile

Aj2

2121 posts in 2124 days


#7 posted 03-23-2019 02:27 AM

It really shouldn’t matter if the knives are sharp. Never count on them to be properly set or the gibs tight.
I recommend to take them out and get them sharpened.
Now that you have a manual setting them is not a mystery.

-- Aj

View pbesong's profile

pbesong

13 posts in 611 days


#8 posted 03-23-2019 02:32 AM

yes, I intend to sharpen them. will need to find a good video on how to do so. manual does seem to cover adjustment.

View pbesong's profile

pbesong

13 posts in 611 days


#9 posted 03-23-2019 05:09 PM

This morning I mounted the jointer on its stand and built a better bracket for the 1/4 HP motor that came with it. I still have to wire up a switch, but direct wiring it to a plug allowed me to test it out and it seems to work fine. Even without sharpening the blades and cleaning up the tables it put a pretty decent face on a 2×4 I ran thru it a few times. Motor runs pretty smooth and the belt seems like the right tension with no slop or runout in the pulleys. Looks like I got a winner! Glad I took a chance on it for $60. I know I’d have been kicking myself if I didn’t. I’ll use it mostly for edging boards. I have a nice DeWalt planer for doing board faces. That was one of the best purchases I made I think.

Thanks for all the advice and comments.

View BlasterStumps's profile

BlasterStumps

1266 posts in 765 days


#10 posted 03-23-2019 05:48 PM

One thing to strive for when sharpening is to do it evenly on all three blades. I have a jig that will allow me to sharpen two blades at the same time so I sharpen two, then switch one out with the third, then after sharpening those two for a bit, I switch out the 2nd blade with the first keeping the third blade in. sounds complicate but really not. Just have to keep track of which is which.

-- "I build for function first, looks second. Most times I never get around to looks." - Mike, western Colorado

View BlasterStumps's profile

BlasterStumps

1266 posts in 765 days


#11 posted 03-23-2019 06:09 PM

Hope you will post pictures of your new jointer.

-- "I build for function first, looks second. Most times I never get around to looks." - Mike, western Colorado

View pbesong's profile

pbesong

13 posts in 611 days


#12 posted 03-23-2019 09:30 PM

I took a couple pix. I’ll upload them as soon as i can get a wifi connection.

View pbesong's profile

pbesong

13 posts in 611 days


#13 posted 03-23-2019 09:37 PM

View pbesong's profile

pbesong

13 posts in 611 days


#14 posted 03-23-2019 09:38 PM

I want to put a safety switch on it eventually but this will make it functional till i get one.

View BlasterStumps's profile

BlasterStumps

1266 posts in 765 days


#15 posted 03-23-2019 11:37 PM

that’s a beaut! Nice find.

Can’t see if yours is the same but my little jointer has a hinged support for the motor so the weight of the motor tensions the belt. I also have a similar switch. I boxed in the chute for the chips and have a port in the bottom for the vac hose.

-- "I build for function first, looks second. Most times I never get around to looks." - Mike, western Colorado

showing 1 through 15 of 18 replies

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com