LumberJocks

Dewalt Planer won't turn on

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by joiner posted 12-14-2018 02:49 PM 1809 views 0 times favorited 10 replies Add to Favorites Watch
View joiner's profile

joiner

3 posts in 254 days


12-14-2018 02:49 PM

Topic tags/keywords: planer

Need help with my planer. DeWalt DW735 planer lightly used over last couple of years. Out of the one year warranty. Used it a couple of weeks ago and worked fine. Went to turn it on and get nothing. Outlet is good, reset switch on machine does nothing. Voltage detector indicates voltage in the cord up to the machine. Voltmeter on the switch shows no power getting to the switch. Anybody with sage advice or wisdom before cracking this thing open?


10 replies so far

View Heyoka's profile

Heyoka

19 posts in 307 days


#1 posted 12-14-2018 03:08 PM

No power to the switch makes me think a broken wire in the power cord near the entrance to the machine or the plug .

-- Heyoka

View ocean's profile

ocean

172 posts in 1288 days


#2 posted 12-14-2018 03:27 PM

I agree with Heyoka. Test from one end to the other on the cord. I don’t know this machine but hopefully you can get to the machine end. If it is buried, you will have to crack it open as you say. Also test the switch while you have it open.

-- Bob, FL Keys

View GR8HUNTER's profile

GR8HUNTER

6348 posts in 1167 days


#3 posted 12-14-2018 04:45 PM

SWITCH for sure :<))

-- Tony---- Reinholds,Pa.------ REMEMBER TO ALWAYS HAVE FUN

View Manyheads's profile

Manyheads

1 post in 1522 days


#4 posted 12-28-2018 12:09 AM

DW735 will not restart after TURNING off for coffee break. Replaced start switch, reset switch etc. no go still would not start. After many hours over several head scratching days and a lot of work, no go. WHACKED motor sharply with a rubber mallet (no joke). Works just fine. Evidently something was loose inside motor case. Sometimes the simple solution is best. Long ago I learned a mule would do anything you want – -you just have to get his attention FIRST

View joiner's profile

joiner

3 posts in 254 days


#5 posted 12-28-2018 01:44 AM

It was the switch before the switch. (At the top of the picture) There’s a contact switch to turn off the machine if the top cover is off. The pole on the switch was loose. Ended up just bypassing it. Works fine now.

View JR545's profile

JR545

24 posts in 1642 days


#6 posted 12-28-2018 01:45 AM

There is also I believe a switch that is depressed when the cover you remove for blade changes is installed. Might also check that switch.

View Scap's profile

Scap

78 posts in 382 days


#7 posted 12-28-2018 03:19 AM



There is also I believe a switch that is depressed when the cover you remove for blade changes is installed. Might also check that switch.

- JR545

I was just thinking the same thing.

View Troph's profile

Troph

1 post in 87 days


#8 posted 05-29-2019 05:13 PM

My Dewalt DW735 also did not start after using it a week ago…...Tried tapping the motor like Manyheads posted and it works just fine….....I still however want to find out what could be loose…brushes connections etc….. I will post when I find the answer…...By the way this is a great forum….....

View Woodknack's profile

Woodknack

12877 posts in 2835 days


#9 posted 06-04-2019 04:16 PM

If you try changing speeds when it’s not running something inside gets disengaged and the planer won’t start. There are a couple of easy solutions floating around forums, sounds like tapping with a mallet works too.

-- Rick M, http://thewoodknack.blogspot.com/

View joiner's profile

joiner

3 posts in 254 days


#10 posted 06-04-2019 05:31 PM

There is a contact switch that shuts the machine off if the lid is off. It’s at the top of the pictures. That was my problem. Went bad pretty quick with little use. I just bypassed it.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com