Collins lunchbox planer

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by MrRon posted 12-20-2017 07:58 PM 564 views 0 times favorited 4 replies Add to Favorites Watch
View MrRon's profile


5913 posts in 4015 days

12-20-2017 07:58 PM

I bought this benchtop planer about 15-20 years ago. It has worked pretty good all that time, but the other day, I tried to use it and flipped the switch; NOTHING. I checked all the obvious things, but could not find why it won’t work. I searched online, but could not find any mention of a Collins planer. I’m guessing it was built by an offshore maker for any number of companies and rebadged by Collins (probably out of business). I tried to find one that looked the same, but to no avail. Does anyone have a Collins or even heard of it? Overall, it’s a pretty well made machine. While using it the last time before it failed to run, I noticed a lot of sparks coming from the brush location. I’m wondering if that may be the problem and if replacing the brushes might fix the problem.

4 replies so far

View Jeff's profile


524 posts in 3966 days

#1 posted 12-20-2017 08:13 PM

Google search brings up several mentions of Collins. There is a Collins Tool Company on the web. Several offers for belts for a 20” planer on Amazon. There is an old thread on Lumberjocks about a Collins planer. Thread originator was Bud2 (?)

View TheFridge's profile


10859 posts in 2258 days

#2 posted 12-20-2017 08:21 PM

Pull the brushes and check em out. Also, make sure you have power coming out of the switch.

-- Shooting down the walls of heartache. Bang bang. I am. The warrior.

View MrUnix's profile


8089 posts in 2971 days

#3 posted 12-20-2017 09:50 PM

Don’t just start throwing money at it without first doing a bit of troubleshooting to narrow down the problem. Just saying “it doesn’t work” leave the field wide open for “solutions” :)

I’d pull the brushes and check them first. Might be the culprit, or might not. Could also be that you need to clean/turn the commutator and/or undercut the mica. But before digging into the motor to check, I’d grab a meter and start tracing voltages to make sure it is where it’s supposed to be. Could just be a broken switch or loose wire. Once you have it narrowed down, then you can start throwing money at it.


-- Brad in FL - In Dog I trust... everything else is questionable

View MrRon's profile


5913 posts in 4015 days

#4 posted 12-20-2017 10:01 PM

Thanks all. When I was young, I wouldn’t even ask this question, but just go ahead and take things apart and fix it. But at 83, simple tasks now become not as simple as previously. A job that would take me 10 minutes to do now can take me an hour or more.

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics