Ryobi BTS20 - Will Not Heel

  • Advertise with us

« back to Power Tools, Hardware and Accessories forum

Forum topic by Doug posted 09-05-2017 04:37 PM 927 views 0 times favorited 5 replies Add to Favorites Watch
View Doug's profile


46 posts in 1904 days

09-05-2017 04:37 PM

Topic tags/keywords: tablesaw refurbishing ryobi bts20 heeling aligning mitre slot fence

I know a lot of folks have much better table saws than I do, but this little guy is pretty handy, and up until last month required almost no special maintenance.

The problem is I am slightly more than 1/16th off… ~3/32 off when measuring from the mitre slot from end to end.

The Ryobi manual is explicit that there are two allen bolts on the back of the blade assembly that when loosened are able to allow me to push the blade over to the correct position and re-tighten the bolts. Yesterday I tried this and it did not work. I tried again about a dozen times and got no results.

Any help from someone who has the same model? I will be upgrading in 2018 to a better saw, but until then I really do not want to be out of business.



-- The only limit to your skills is your willingness to learn

5 replies so far

View Loren's profile


10477 posts in 4254 days

#1 posted 09-05-2017 05:52 PM

It seems to me likely you haven’t used enough
force. Much of the weight of the saw’s internals
will be on the point that needs to move. In
adjusting cabinet saws I have reached up
from underneath to lift the entire assembly to
make it easier to shift it.

View Doug's profile


46 posts in 1904 days

#2 posted 09-05-2017 08:44 PM

thanks will give that a try. i actually had a 2×4 backed by shims to move it when the bolts were loosened. then it just popped right back out of line after i tightened the bolts and removed the 2x. What bothers me more is what the hell did i do to knock it out of line…i’ll just settle for fixing it…

-- The only limit to your skills is your willingness to learn

View MrUnix's profile (online now)


7595 posts in 2805 days

#3 posted 09-05-2017 09:32 PM

I checked the manual online and didn’t see anything that addressed aligning the blade to the miter slots… where is it? Only thing I could find was aligning the fence to the blade. Anyway, it sounds like you need to loosen more than just two screws at the back of the assembly… on most saws of that design, there are at least 4 mounting points to the table top. If only the back two are being loosened, then the others are probably preventing it’s movement. Parts diagram is horrible, and I can’t identify what bolts are holding what. I think you need to crawl up under there and see what’s going on – ignore the manual :)


-- Brad in FL - In Dog I trust... everything else is questionable

View Doug's profile


46 posts in 1904 days

#4 posted 09-06-2017 09:34 PM

yeah, i am thinking that too. there are two large screw heads on the assembly toward the rear of the saw accessible when the plate is off. I may try them too and see if that makes the difference.

The instructions in the user manual were on page 25?

-- The only limit to your skills is your willingness to learn

View Doug's profile


46 posts in 1904 days

#5 posted 09-11-2017 07:04 PM

The saga continues. Spoke with Ryobi tech support and they confirm only those bolts are loosened and it should move when tapped.

Tried lifting from below – and that did not help.

Going to look for what might be holding things in place – some lubrication maybe?

I see a new table saw, stepping up to a hybrid.

Will update when I figure out the right fix.

-- The only limit to your skills is your willingness to learn

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics