LumberJocks Woodworking Forum banner
  • Please post in our Community Feedback thread for help with the new forum software! If you are having trouble logging in, please Contact Us for assistance.
1 - 12 of 12 Posts

·
Registered
Joined
·
121 Posts
I have multiple tabs open in chrome and they are all speedy except LumberJocks.
At times it is so slow its painful.

Does anybody else have slow loading pages here or is it just me.

Not only do the pages load slowly but if I scroll up and down the site or a thread, I get a black and white cross hatch pattern then it will load the content.

Thanks,
 

·
Registered
Joined
·
973 Posts
I haven't been on LumberJocks much for the last few months. Since the weather's getting cooler and night falling sooner, I started dropping by again a couple weeks ago. It definitely seems slower than it did when I was a more frequents visitor a few months ago. The forums seem particularly slower to load.
 

·
Registered
Joined
·
175 Posts
I use AdBlock with Chrome, not to be confused with the 'Plus' or 'Super' versions. Nothing against them, I don't even remember how I picked this one over the others.

I have to note that if we all use ad blockers then we'll have to start paying for our web sites. Not complaining, just fair warning.
 

·
Registered
Joined
·
7,855 Posts
Actually I am using my Acer tablet, four tabs open, with Wifi and the respnse is fairly decent for a cheapo tablet.
It really slows down when someone is streaming a movie but that is not the fault of the tablet.
 

·
Registered
Joined
·
2,874 Posts
I too have a lot of difficulties with the LJ site being slow. Most of the time the projects won't load at all, or I'll have to reload them multiple times to get the pics to show.
 

·
In Loving Memory
Joined
·
15,066 Posts
The speed and ads aren't a problem here but the non functioning backspace key and back arrow have been making for a miserable LJ experience!
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top