LumberJocks Woodworking Forum banner

Lathe Help

949 Views 4 Replies 2 Participants Last post by  Gixxerjoe04
So i picked up a lathe yesterday, the pulley's needed to be replaced and came with it so figured no problem. Well i got the set changed on the motor and now i can't get one piece off the other part. I broke quite a bit off the pulley trying to break it free only to realize it was being held on by a little clamp behind the black speed adjustment thing. It's probably next to impossible to get behind it with out taking the whole thing off but i don't know how or if it's even possible to do. Tried getting some small allen wrenches behind it to pry it off but it hasn't worked. Anyone have any insight on this problem?
Wood Bumper Automotive exterior Computer hardware Audio equipment

Road surface Asphalt Font Circle Concrete


See less See more
1 - 5 of 5 Posts
This thing is about to make me go crazy, tried calling harbor freight tech support and of course they closed 5 minutes before i called.
Yea feel like an idiot, i went and bought a pair before knowing there was a hidden one and at the time didn't know about the 90 degree ones they sell. Wasted $15 on the pair when i needed the other, hopefully it wont be a pain to get it back on and the variable speed screw back in, in the right spot. A night of wasted time and frustration.
Got the snap ring out and was excited to finally get it fixed. Well the dang thing is still stuck on there like a rock. Tried a propane torch, wd40, called harbor freight making sure there wasn't something invisible on it I'm missing. This thing is about to get a sledge hammer. Don't know what else to do.
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.