LumberJocks Woodworking Forum banner
  • Please post in our Community Feedback thread for help with the new forum software! If you are having trouble logging in, please Contact Us for assistance.
1 - 20 of 35 Posts

·
Registered
Joined
·
297 Posts
I had the same problem. It's all the ads, which I assume are loaded as separate pages. So when you press the "back" button, all it is doing is resetting the ad, rather than returning to the previous webpage.

The easiest way to fix this is to use an adblocking plugin in your browser.
 

·
Registered
Joined
·
4,080 Posts
I have the same problem and I use FireFox.
You can right click on the back arrow and a drop down list will show you where "back" will take you.
Notice about the top 7 or 8 destinations are the same place where you are.
Click on the next one down that is different. That will be where "back" should go.
This has happened before. Usually gets fixed in a day or two.
 

·
Registered
Joined
·
2,220 Posts
Same problem here. The abundance of adds, and the problems that they are causing, is now starting to make this site quite frustrating instead of the enjoyable site that it always has been.
 

·
Registered
Joined
·
1,353 Posts
Huge Firefox fan, but I notice this same phenomenon doesn't happen on my work computer which has Chrome. I don't know if that is a factor of Chrome, or something the company network does. I still see the ads in the side panel and at the top.

-Brian
 

·
Registered
Joined
·
3,728 Posts
Cricket, it doesn't happen with all versions of Firefox, it also doesn't happen if you have an ad blocking add-on installed.
I have a test computer that I run simulation on to replicate problems. It has no ad-block, no malware blocker and no AV. It is surprising how many pieces of junk get loaded in one of these windows.

That computer hasn't had a Firefox update sinve V.29. We are now at V.36. if everything is current.
 

·
Administrator
Joined
·
3,155 Posts
Okay, I tested this again.

In Chrome (my default browser) I found no issues.

In Internet Explorer (fully updated) I found no issues.

In Firefox (fully updated) I was also unable to use the back button after viewing multiple images within a project.

I will add this information to the bug report.
 

·
Registered
Joined
·
756 Posts
One good workaround is to open links in new tabs instead. I almost always middle-click or (Windows/Command+click) on links on most pages to open them in new background tabs, then I close each new tab after I've read it.
 

·
Registered
Joined
·
8 Posts
Having the same problem using Facebook - gets very frustrating. Work around with the right click buttons but still I then go back to the original page of the article so I have to go then to the page I last was looking at. I have a similar problem with Facebook - the further down I go the more it locks up and I have to wait - the same problem - ads. A computer store salesman gave me a website to download an ad cleaner - going to try that tonight. Will also check Firefox's add-on for this.
 

·
Registered
Joined
·
1,037 Posts
Mine was happening in Firefox and right-clicking the back arrow showed approximately 6-7 times the same page had been opened. And I just clicked once to see a project! So I can click the back arrow 8 times and get back to where I want or right click and select the page I want. I just installed AdBlock plugin for Firefox and it fixed the issue. I'm running the latest version of firefox. Doesn't seem to be happening in IE 11, but it is doing something, because it takes a long time to open the project I went to or to go back. AdBlock sure seems to help.
 
1 - 20 of 35 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top