LumberJocks

Steve

  • Advertise with us
View Steve's:homeworkshopprojects (0)blog (0)reviews (0)forum topics (2)buddies (0)favorites (0)activity logWatch
Steve

Buddies

None so far

10 posts in 787 days

Location: Harrisburg, PA
Website:

I'm retired and have recently gotten back into woodworking. I have a small garage shop and I enjoy working various projects. Recently purchased a Leigh mortise & tenon jig and looking forward to playing with it.

-- Steve, Harrisburg PA

Latest Activity

started topic Laguna Fusion 2 tablesaw motor play 04-19-2021 11:52 PM
commented on Steve's Profile 04-19-2021 11:18 PM
replied on 6" jointer 05-05-2019 04:35 PM
replied on 6" jointer 03-20-2019 02:35 PM
replied on 6" jointer 03-19-2019 11:28 PM
replied on 6" jointer 03-19-2019 09:49 PM
replied on 6" jointer 03-19-2019 12:13 AM
replied on 6" jointer 03-18-2019 12:05 AM
started topic 6" jointer 03-17-2019 06:24 PM
commented on Steve's Profile 03-17-2019 05:59 PM
signed up Steve's Profile 03-17-2019 05:08 PM

Latest Projects

None so far

Latest Blog Entries

None so far


Grab widget

2 comments so far

View Steve's profile

Steve

10 posts in 787 days


#1 posted 03-17-2019 05:59 PM

I’m in the Harrisburg PA area and looking for a used 6” jointer. I’ve been looking on Craigslist but haven’t found much yet. Never realized how many jointers Sears sold! Seems like 3/4 of the CL hits are Craftsman. If anyone knows of any 6” jointers with a decent sized table (36-40”?) I’d be interested and would appreciate any leads. Thanks,

Steve

-- Steve, Harrisburg PA

View Steve's profile

Steve

10 posts in 787 days


#2 posted 04-19-2021 11:18 PM

Anyone have a fairly new Laguna Fusion 2 tablesaw? I bought mine April 2020 and have lightly used it since as a hobbyist. I recently had issues cutting consistent miter joints and noticed that the motor bracket assembly had a fair amount of play in it. I am able to “jiggle” the motor back and forth when the motor housing cover is removed. There is an audible “klunk” sound PLUS the blade moves about .01” on my dial indicator. I’ve got a call into Laguna tech support but I’m wondering if any Fusion 2 owners have the same issue? Thanks for any input,
Steve

-- Steve, Harrisburg PA

Have your say...

You must be signed in to post the comments.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com