LumberJocks

All Replies on Waterlox problems, help needed please

  • Advertise with us
View redmosquito1's profile

Waterlox problems, help needed please

by redmosquito1
posted 01-28-2017 06:39 AM


2 replies so far

View Pezking7p's profile

Pezking7p

3230 posts in 2191 days


#1 posted 01-28-2017 01:19 PM

Waterlox is intended to be applied pretty heavy and left on, not wiped off, and no sanding between coats. Three to four coats are pretty much required and before that point the finish is going to appear uneven. I think the problem is you are sanding and wiping off excess and putting on extra coats in some areas versus other areas, and that’s messing up the process of layering on finish thickness.

At this point I’m not sure what condition your piece is in with respect to number of coats. I would apply a few more coats and see what happens. Worst case you sand everything back and start over if it doesn’t work.

-- -Dan

View Kirk650's profile

Kirk650

674 posts in 1288 days


#2 posted 01-28-2017 02:39 PM

I’m a fan of Waterlox. The first coat is always ugly. Second coat looks good and third coat looks great. Normally I apply it with a foam ‘brush’ and put a liberal coat on horizontal surfaces, but only thin coats on vertical surfaces (so that I won’t get sags or runs).

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com