LumberJocks

All Replies on Laguna Jointer Rest Switch

  • Advertise with us
View JSMorgan's profile

Laguna Jointer Rest Switch

by JSMorgan
posted 12-04-2018 01:14 AM


6 replies so far

View therealSteveN's profile

therealSteveN

2784 posts in 959 days


#1 posted 12-04-2018 01:26 AM

Should be quite visible on the motor if you have one. Seeing as how they likely knew which model you had, I’d assume you do. Small red button, with a metallic surround.

-- Think safe, be safe

View JSMorgan's profile

JSMorgan

35 posts in 662 days


#2 posted 12-04-2018 01:42 AM

TheReal: That’s sort of what I was looking for but did not see it. You say on the motor but there is a junction box that also leads to the main power switch mounted on the frame I was looking at. Laguna said it was in a “black box” which is what I was looking at. Also, I checked the motor and did not see anything either.

Thank you!

View fly2low's profile

fly2low

69 posts in 482 days


#3 posted 12-04-2018 09:39 AM

If it is new, you might want to take the cover off of the switches and check the wiring. When new, mine worked fine for a month or so, then suddenly stopped. Took the cover off, two of the wires had fallen off the switch, and two more were loose. I talked to CS about this.
Works great otherwise

-- Rich Gig Harbor, WA

View DRas's profile

DRas

1 post in 162 days


#4 posted 01-05-2019 05:14 AM

JSMorgan

Did you find your answer? My motor would not turn on. I called Laguna. The jointer is brand new. They told me in the black box is a blue button, and they call this the reset button. No luck for me. But, I did hold in the reddish button that is very close to the blue button. The motor started, but, would turn off when I let go of the reddish button.

Was good to know that it would turn on. My guess is the blue button needs to be pulled out.

Let us know if you figured it out.

DR

View AlaskaGuy's profile

AlaskaGuy

5271 posts in 2694 days


#5 posted 01-05-2019 05:18 AM



I was using my Laguna 8” helica cutter head jointer. All of a sudden it stopped. I contacted Laguna and they said to look for a reset switch which may have popped. I either did not find it or it had not popped. Anyone know where it is located?

Thanks,
Jerry

- JSMorgan


You would think good customer service would include telling you where it’s located. You don’t have a manual with a parts diagram?

-- Alaskan's for Global warming!

View fly2low's profile

fly2low

69 posts in 482 days


#6 posted 01-05-2019 07:50 AM

When I talked to CS about my wires not being fastened like they should have been, I also shared my opinion of their manual. Subpar would be a compliment to that thing

-- Rich Gig Harbor, WA

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com