LumberJocks

All Replies on laguna 1412 blade guide isssue

  • Advertise with us
View trsnider's profile

laguna 1412 blade guide isssue

by trsnider
posted 11-21-2018 07:19 PM


6 replies so far

View ArtMann's profile

ArtMann

1441 posts in 1352 days


#1 posted 11-22-2018 12:11 AM

Not me! I have never had the issue.

View GaryCK's profile

GaryCK

56 posts in 585 days


#2 posted 11-22-2018 12:46 AM

That’s never been a problem for me with my 1412. Sorry I don’t have wisdom to share.

-- Gary, Wisconsin

View trsnider's profile

trsnider

152 posts in 2546 days


#3 posted 11-22-2018 01:28 AM

Thanks. Talked to Laguna technical support. They’re going to send me replacements for the blade guide assemblies. They thought there was something wonky with mine. We’ll see if that helps.

View fly2low's profile

fly2low

88 posts in 633 days


#4 posted 11-22-2018 11:06 PM

I have had zero issues with my Laguna BS. I have found Lagunas customer service to be very helpful, I have found Laguna operator manuals to be much less than helpful

-- Rich Gig Harbor, WA

View AHuxley's profile

AHuxley

874 posts in 3857 days


#5 posted 11-23-2018 12:56 AM



Thanks. Talked to Laguna technical support. They’re going to send me replacements for the blade guide assemblies. They thought there was something wonky with mine. We’ll see if that helps.

- trsnider

There has been at least one other report of this, same response, they sent new guides and all was well.

View Andybb's profile

Andybb

2149 posts in 1139 days


#6 posted 11-23-2018 06:06 PM

Never had an issue but as you found out their customer support is excellent. Absolutely love my 1412.

-- Andy - Seattle USA

Have your say...

You must be signed in to reply.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com