LumberJocks

Reply by SwampFox76

  • Advertise with us

Posted on Delta 36 725T2 starter capacitor issue

View SwampFox76's profile

SwampFox76

46 posts in 464 days


#1 posted 03-03-2021 04:19 PM


Sounds like you are closing in on the issue, painful as it is. Maybe try to talking Delta into sending you the new motor and you will return the old one, cause of covid issues. (reason of the year for anything)
Try to blow some dust out, and check the pads, pretty sad that Delta with all their history can not find or already
have a good supplier of motors, and now the manager chase.
Best of Luck

- cut50

I’ve gotten a little further too. I want to post this here so anybody having this issue hopefully they can easily stumble across this post. The post where I talked about the issue with the friction pads, the Facebook link in my previous post, I got in contact with the guy who started that post he told me to get in contact with a guy that was in the comments by the name of Frank Heizler, you can find that information in the link to his Facebook page. Frank got back to me sent me a PDF of instructions for a kit that he sells to help improve the issues with the motor.
Here’s the link to that kit

Non T2 kit
https://py.pl/MyoT4

T2 kit
https://www.paypal.com/instantcommerce/checkout/5ECX95JK3HLZJ

The original guy I spoke with said he also sends those instructions out with the kit. It doesn’t seem like it’s too hard to do. I’m going to be ordering this kit tomorrow hopefully it gets to me as soon as possible and I’ll keep you guys posted.


DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com