LumberJocks

Reply by sansoo22

  • Advertise with us

Posted on Leecraft TS insert is making me nervous

View sansoo22's profile

sansoo22

152 posts in 106 days


#1 posted 05-21-2019 06:30 PM

I own that saw and a handful of Leecraft inserts for it. I know the arbor on mine isn’t terribly well balanced and it vibrates on startup every time. Not enough to get plastic flakes from the ZCI tho. I went thru the same overall process you did to align everything in compliance with my OCD. Blade and fence are within 0.02 mm (~0.0008”) of parallel with the miter slot which isn’t quite as good as you have so call me impressed there.

The only thing i could think to check is any side to side movement of the ZCI itself. Mine all fit rather snug and only required adjusting the depth screws to make them flush with the top. I know the DW-2 insert has a side screw on it that can be used to adjust it laterally. I think it should have 2 on the side but whatever at least it has the one.

I will add that my ZCI isn’t exactly 0 clearance. My process of making it work with the riving knife widened it about 1/64” from true 0 clearance.

I guess as a last ditch, maybe i was a bonehead, check would be to make sure you tightened both of the adjustment bolts for the blade housing on the back of the saw. I know i just about forgot one of them when i was done with my adjustments.


DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com