LumberJocks

Powermatic 54A Jointer #2: Chips

  • Advertise with us
Blog entry by Jerome posted 09-08-2019 12:47 AM 570 reads 0 times favorited 2 comments Add to Favorites Watch
« Part 1: Beginners issues Part 2 of Powermatic 54A Jointer series no next part

Recently I began using my jointer again and for some reason wood chips are being blown back towards the indeed side during operation. I checked the dust pist and it isnt clogged. My cut depth is set to 1/64 of an inch. What could be my problem?

-- Jerome, Marietta, GA



2 comments so far

View Andybb's profile

Andybb

2029 posts in 1084 days


#1 posted 09-08-2019 02:20 AM

I’d check the area further up in the dust chamber behind the knives. Chips get packed in behind the knives and don’t make it down into the chamber on my Grizzly even when the chamber looks empty. It takes a vacuum hose or a long dowel or coat hanger to bust them loose. The problem is that my dust collector isn’t strong enough to remove those large chips so they get packed in there and back up.

-- Andy - Seattle USA

View Jim Jakosh's profile

Jim Jakosh

23198 posts in 3586 days


#2 posted 09-08-2019 12:33 PM

Hi Jerome, Mine does that occasionally and it is always that the outfeed chute for the chips is plugged with chips. I clean them out with my hand ( the machine is always OFF) but then I use a stick to clean way up in there and and a bunch more come out and the problem goes away. Look way up in there.

cheers, Jim

-- Jim Jakosh.....Practical Wood Products...........Learn something new every day!! Variety is the Spice of Life!!

Have your say...

You must be signed in to post the comments.

DISCLAIMER: Any posts on LJ are posted by individuals acting in their own right and do not necessarily reflect the views of LJ. LJ will not be held liable for the actions of any user.

Latest Projects | Latest Blog Entries | Latest Forum Topics

HomeRefurbers.com